how can I get hios 4.1. I'm using spark 2